No high beam indicator on instrument panel (Saab 9-5)

Few days ago, in my Saab 9-5 from 2002, I stared to have a problem with my high beam  indicator on my instrument panel. When I switched my headlights to high beam – the indicator on the dashboard just did not appear. Strange thing was that the high beam lights worked perfectly! Also the Saab Information Display kept telling me randomly, that the front light failed which was not a true at all.

When you drive in completely dark it was quite easy to see what light I had, high beam or not, but it was easy to forget and theoretically I could blind other drivers.

So it was a very strange failure.

What I found was the faulty orange electronic relay (Saab part No. 41 09 070):

no-high-beam-indicator-saab-9-5-relay-in-box

 

It was quite difficult to remove the orange cover from the relay, I was struggling to undo all three clips in the same time and the cover cracked in one place, but it is nothing to worry about đŸ™‚

I found that two soldered joints cracked and only what I had to do was to re-solder the cracked joints (there is a chance that I damaged one of these joints, however after repairing both of them everything started to work properly).

no-high-beam-indicator-saab-9-5-repaired-relay

 

The repair costed me £0.00 đŸ™‚

Now high beam indicator works absolutely fine and I also have no more front light failure info on my SID:

no-high-beam-indicator-saab-9-5-high-beam-indicator-works-againSony C6833 (2.96mm, f/2.4, 1/25 sec, ISO400)

2,035 total views, 1 views today

Leave a Reply

Your email address will not be published. Required fields are marked *

CAPTCHA
Change the CAPTCHA codeSpeak the CAPTCHA code